December 2015

iOS 9.2 supported by SyncShield

Published 18th December 2015. Season’s Greetings from team Capricode! Just a quick update for iPhone and iPad users: SyncShield is supporting the new iOS 9.2. Enjoy!